Langkah-Langkah Melakukan Konfigurasi Cisco Router Menjadi Internet Gateway

Pada artikel ini saya akan membahas bagaimana cara melakukan konfigurasi pada perangkat cisco routerĀ  agar dapat difungsikan menjadi internet gateway. Gateway sendiri merupakan sebuah perangkatĀ  yang fungsinya untuk mengoneksi sebuah jaringan komputer terhadap satu jaringan komputer lain, baik satu atau lebih, yang menggunakan protocol informasi yang tidak sama. Sehingga memudahkan perangkat jaringan yang terkoneksi untuk melakukan akses internet. Dalam konfigurasi kali ini saya sudah merancang sebuah topologi jaringan yang digambarkan pada gambar dibawah ini.

Pada gambar topologi di atas terdapat sebuah router cisco  yang digunakan sebagai perantara antara laptop dan Internet, router ini yang nantinya akan di fungsikan sebagai router internet gateway agar client yang berada di bawahnya mendapatkan fasilitas internet dari ISP, untuk koneksi antara router ke Internet menggunakan media kabel yang terhubung ke interface fa0/0 dan router ke PC terhubung ke interface fa0/1. Dan berikut ini merupakan daftar list peralatan yang saya gunakan dalam jaringan yang dirancang sesuai dengan gambar topologi jaringan diatas.

  1. Cisco router
  2. Kabel yang sudah terhubung ke jaringan LAN sebagai sumber internet
  3. Laptop untuk konfigurasi dan juga sebagai pengguna internet
  4. Kabel straight untuk menghubungkan antara cisco router dan laptop dalam jaringan
  5. Kabel konsol sebagai penghubung laptop ke cisco router untuk melakukan konfigurasi

Setelah semua perangkat sudah tersusun dan terhubung sesuai dengan topologi jaringan, yang selanjutnya adalah melakukan konfigurasi. Sebelum melakukan konfigurasi pastikan juga laptop sudah terinstal driver cable console dan juga menginstal software Putty agar bisa melakukan konfigurasi. Jika sudah maka langsung saja buka software Putty dan melakukan konfigurasi. Berikut ini merupakan langkah langkah dalam melakukan konfigurasi cisco router menjadi internet gateway.

  1. Request dhcp client

DHCP client adalah suatu perangkat client yang mengoperasikan perangkat lunak DHCP client sehingga dapat tersinkronisasi dengan DHCP server untuk menerima alamat IP,DNS, dan default gateway secara otomatis. Langkah langkah untuk melakukan konfigurasi request dhcp client sebagai berikut :

Router>enable
Router#configure terminal
Router(config)#interface g0/0
Router(config-if)#no shutdown
Router(config-if)#ip address dhcp
*Nov 23 03:30:21.035: %DHCP-6-ADDRESS_ASSIGN: Interface FastEthernet0/0 assigned DHCP address 192.168.3.5, mask 255.255.255.0, hostname Router

Jika langkah pertama ini berhasil maka router cisco akan otomatis mendapatkan ip address dari router ISP dan pada tahap ini seharusnya router cisco sudah mendapatkan akses internet dari router ISP, sebelum masuk ke tahap selanjutnya silahkan cek ip dhcp client dan tes ping ke google.com pada router cisco terlebih dahulu, dan berikut ini caranya :

Cek IP DHCP Client pada Router Cisco :

Router#sh ip interface briefInterface IP-Address OK? Method Status ProtocolGigabyteEthernet0/0 192.168.3.5 YES DHCP up upGigabyteEthernet0/1 unassigned YES unset administratively down downSerial0/0/0 unassigned YES unset administratively down down

Setelah dicek terlihat router mendapatkan ip addres 192.168.3.5 dari penyedia internet atau ISP.

Cek ping router ke Google.com

Router#ping google.com
Translating “google.com”…domain server (8.8.8.8) [OK]
  1. Buat IP Address untuk Interface Fa0/1

Setelah router cisco sudah mendapatkan ip address dari router ISP dan mendapatkan fasilitas internet, maka langkah selanjutnya adalah membuat ip address untuk interface yang mengarah ke sisi client (g0/1), dan berikut ini merupakan langkah konfigurasinya :

Router(config)#interface g0/1
Router(config-if)#ip address 30.30.30.1 255.255.255.0
Router(config-if)#no shutdown
  1. Buat DHCP Excluded Address

Konfigurasi ini bertujuan agar menyimpan ip address dengan range tertentu dan tidak akan di distribusikan oleh layanan dhcp server, berikut merupakan langkah konfigurasinya :

Router(config)#ip dhcp excluded-address 30.30.30.1 30.30.30.10

Dengan menerapkan cara di atas maka router akan menyimpan ip address dengan range 30.30.30.1 sd 30.30.30.10 dan tidak akan di berikan oleh client pada Fasilitas dhcp server.

  1. Buat DHCP Server

Konfigurasi selanjutnya adalah dengan melakukan konfigurasi dhcp server yang bertujuan agar router dapat mendistribusikan ip address otomatis ke client yang terhubung langsung ke router cisco, langkah konfigurasinya sebagai berikut :

Router(config)#ip dhcp pool IP-Client
Router(dhcp-config)#network 30.30.30.0 255.255.255.0
Router(dhcp-config)#default-router 30.30.30.1
Router(dhcp-config)#dns-server 8.8.8.8
  1. Buat Name-Server & Access List

Fungsi Name-Server adalah sebagai database domain yang terdapat pada jaringan, umumnya name-server ini di isi dengan ip router ISP jika pada materi ini ip router ISP adalah 192.168.3.1 dapat di lihat pada langkah pertama dimana router cisco mendapatkan ip address 192.168.3.5, jika anda kurang yakin silahkan lakukan ping ke ip 192.168.3.1. Sedangkan access list berfungsi untuk memfilter atau membatasi paket berdasarkan ip address dan di terapkan pada interface, untuk memudahkan pemahaman silahkan lihat pada konfigurasi di bawah ini :

Router(config)#ip name-server 192.168.3.1
Router(config)#access-list 1 permit 30.30.30.0 0.0.0.255

Router membuat sebuah access list dengan nilai 1 dan action permit (ijinkan) untuk ip dengan network 30.30.30.0 dan wildcard 0.0.0.255 (mask 255.255.255.0) dan access list dengan nilai 1 ini yang nantinya akan di panggil saat konfigurasi nat overloding, fungsi ini sebenarnya bertujuan untuk mendefinisikan bahwa network tersebut di ijinkan untuk melewati access list dengan action permit diatas.

  1. Buat NAT Dynamic Overload

Network Address Translation pada cisco terbagi menjadi 2 yaitu static dan dynamic untuk NAT Static bersifat one to one dan Dynamic memiliki beberapa Opsi seperti NAT dengan Pool dan NAT Overload. Nat Pool umumnya di gunakan untuk teknik loadbalancing sedangkan NAT Overload adalah NAT yang paling sering di gunakan untuk konfigurasi Internet Gateway dengan cara kerja semua request atau permintaan client local yang menuju ke internet akan di berikan ke satu alamat ip global/outside (IP Public) tentu dengan cara ini akan menghemat penggunaan ip public pada sisi ISP. Untuk melakukan konfigurasi NAT Overload pertama-tama kita harus mendefinisikan interface mana mengarah ke sumber internet (ISP) dengan cara :

Router(config)#ip nat inside source list 1 interface g0/0 overload

Pada cara di atas bertujuan untuk mendefinisikan interface g0/0 yang nantinya akan bertugas menjadi interface overload atau jalur utama menuju internet, sedangkan skript source list 1 yakni mengijinkan network yang sudah terdaftar pada access list 1 tersebut untuk menuju ke internet melalui interface g0/0. Setelah mendefinisikan interface overload maka selanjutnya adalah mendefinisikan status pada masing-masing interface tersebut pada menu IP NAT dengan cara :

Router(config)#interface g0/0
Router(config-if)#ip nat outside
Router(config-if)#exit
Router(config)#interface g0/1
Router(config-if)#ip nat inside

Interface g0/0 berstatus interface yang akan mengarah ke jalur internet (outside) sedangkan Interface fa0/1 berstatus yang akan mengarah ke sisi client local (inside). pada tahap ini seharusnya konfigurasi internet gateway pada router cisco telah selesai, untuk pengujian dapat di lakukan pada sisi client dengan cara mengetikan ipconfig pada CMD laptop untuk mengetahui ip address dan juga melakukan ping ke google.com apakah laptop benar benar mendapatkan akses internet.

Untuk lebih memudahkan pemahaman mengenai konfigurasi cisco router menjadi internet gateway, saya telah membuat video tutorial dalam chanel youtube saya. Dalam video merupakan praktikum langsung terhadap perangkat fisik dan didalam video juga disertakan penjelasan terhadap langkah langkah dalam menyusun jaringan sesuai dengan topologi, dengan video tersebut semoga akan lebih menambah pemahaman anda mengenai konfigurasi cisco router sebeagai internet gateway. Diharapkan juga anda memberikan feedback yang membangun sehingga akan menjadi bahan evaluasi saya agar menjadi lebih baik. Berikut merupakan link youtubenya : https://youtu.be/gkKY0PXG6JQ

You may also like...

Leave a Reply

Your email address will not be published.