Konfigurasi SSH, NAT Dynamic, ACL Standard dan Switchport Security

Topik:

  1. Konfigurasi Remote SSH Pada Router Cisco
  2. Konfigurasi Dynamic NAT (Network Address Translation) Pada Router Cisco
  3. Konfigurasi ACL Standard Pada Router Cisco

Pengertian:

Jaringan Komputer adalah suatu sistem yang terdiri atas komputer dan perangkat jaringan lainnya yang bekerja bersama-sama untuk mencapai suatu tujuan yang sama (Budhi Irawan, 2005:5). Administrasi jaringan komputer adalah sebuah pekerjaan dari para administrator jaringan yang bertugas untuk mengatur sebuah jaringan komputer baik dalam skala kecil maupun skala besar. Dalam sebuah pembuatan administrasi jaringan komputer terdapat beberapa hal yang perlu diperhatikan agar dapat terkoneksi, antara lain adalah perangkat perantara seperti Router dan Switch, perangkat akhir seperti Laptop atau Komputer, media jaringan seperti kabel LAN baik bertipe Straight atau Cross dan beberapa peralatan penunjang seperti kabel Console dan alat krimping kabel LAN beserta LAN Tester.

Administrasi Jaringan Komputer memiliki beberapa langkah-langkah agar suatu jaringan dapat terbentuk. Seperti Subnetting, konfigurasi VLAN (Virtual LAN),  konfigurasi DHCP untuk pengalamatan IP secara otomatis (dinamis), konfigurasi Routing EIGRP (Cisco Proprietary), konfigurasi Remote SSH, konfigurasi Port Security pada perangkat Switch (Manageable), konfigurasi NAT (Network Address Translation) untuk mengkoneksikan dengan Internet, konfigurasi ACL (Access Control List) serupa seperti Firewall yang berfungsi untuk membatasi akses, dan Konfigurasi keamanan standar. Pada administrasi jaringan memiliki beberapa fungsi, yaitu  untuk membuat server, mengelola jaringan yang tersambung dengan server, memonitor jaringan, dan mengamankan transfer data dalam jaringan tersebut.

Dalam hal ini Router adalah sebuah alat (Hardware) yang berfungsi sebagai penghubung antar dua atau lebih jaringan untuk meneruskan data dari satu jaringan ke jaringan yang berbeda. Routing adalah suatu protokol yang digunakan untuk mendapatkan rute dari satu jaringan ke jaringan yang lain. Rute ini, disebut dengan route dan informasi route secara dinamis dapat diberikan ke router yang lain ataupun dapat diberikan secara statis ke router lain. Routing adalah proses dimana suatu router mem-forward paket ke jaringan yang dituju. Suatu router membuat keputusan berdasarkan IP address yang dituju oleh paket. Semua router menggunakan  IP address tujuan untuk mengirim paket. Agar keputusan routing tersebut  benar, router harus belajar bagaimana untuk mencapai tujuan. Ketika router menggunakan routing dinamis, informasi ini dipelajari dari router yang lain.

Switch adalah perangkat keras sekaligus sebagai perangkat perantara yang berfungsi sebagai konsentrator atau berfungsi untuk menghubungkan beberapa komputer pada jaringan yang sama. Pada artikel ini saya akan lebih fokus terhadap topik yang ada di atas, yakni mengenai konfigurasi Remote SSH, NAT Dynamic, ACL Standard, dan Port Security pada perangkat Switch. Semua perangkat pada artikel ini menggunakan perangkat Cisco seperti Router Cisco dan Switch Cisco (Manageable).

Secure Shell atau SSH adalah protokol transfer yang memungkinkan penggunanya untuk mengontrol sebuah perangkat secara remote atau dari jarak jauh melalui koneksi internet. Pada artikel ini saya menggunakan SSH sebagai Remote Router karena lebih secure dibandingkan Telnet.

Dynamic NAT adalah proses atau mengubah IP Address Private menjadi IP Address Public dan sebaliknya, namun dengan cara yang otomatis. Pada artikel ini saya menggunakan Dynamic NAT karena proses NAT nya yang secara otomatis tidak seperti Static NAT yang mengharuskan NAT manual setiap kali ada perangkat baru yang ingin mengakses internet.

Access Control List adalah daftar akses kontrol yang berisi perizinan serta data kemana user akan diberikan izin. Pada artikel ini saya menggunakan ACL Standard yakni ACL yang menggunakan penomoran dari 1 sampai 99. ACL ini saya gunakan untuk memblok akses dari jaringan laptop saya ke jaringan laptop yang lain.

Swicth Port Security merupakan mekanisme keamanan yang digunakan pada Switch Cisco. Dengan port security ini kita dapat membatasi jumlah host yang dapat terkoneksi pada sebuah port yang ada di Switch, serta menentukan host mana saja yang bisa terkoneksi ke Switch. Pada mekanisme ini terdapat tiga violation yang dapat digunakan yakni protect, shutdown, dan restrict. Interface (port) yang menerapkan violation protect akan membuang atau mendrop paket yang dikirim oleh host yang tidak diijinkan. Interface yang menerapkan violation shutdown secara otomatis akan menonaktifkan jalur interface tersebut apabila paket yang dikirim melalui host yang tidak diijinkan. Sementara interface yang menggunakan violation restrict akan menampilkan sebuah notifikasi apabila paket yang dikirim melalui host yang tidak diijinkan.

Konfigurasi Remote SSH Pada Router Cisco

Perangkat yang diperlukan:

  1. Laptop
  2. Kabel Console
  3. Kabel LAN
  4. Router Cisco
  5. Software PuTTY

Langkah-langkah:

  1. Masukkan kabel Console pada port RJ45 di Laptop dan port Console pada Router Cisco
  2. Masuk ke “Device Manager” cek pada driver COM (sebelumnya harus menginstall drive Consolenya terlebih dahulu)
  3. Masuk ke Software PuTTY, pilih “Serial” dan masukkan “Serial Line” dengan COM yang sesuai
  4. Konfigurasi Remote SSH pada Router
  5. Sambungkan kabel LAN (Straight) ke Router pada port (bebas) menuju ke Laptop atau Komputer
  6. Set IP pada Router dan Laptop, pastikan Laptop dalam satu network yang sama dengan Router
  7. Pada Laptop atau Komputer, buka Command Prompt lalu ketikkan perintah “ssh -l (username) (IP Router)”

Topologi

Topologi Remote SSH

Konfigurasi:

R1>enable

R1#configure terminal

R1(config)# enable secret (password)

R1(config)#ip domain-name (domain)

R1(config)#username (username) secret (password)

R1(config)#line vty 0 4

R1(config-line)#transport input ssh

R1(config-line)#login local

R1(config-line)#exit

R1(config)#crypto key generate rsa (1024)

Video Penjelasan:

Konfigurasi Dynamic NAT (Network Address Translation) Pada Router Cisco

Perangkat yang diperlukan:

  1. Laptop
  2. Kabel Console
  3. Kabel LAN
  4. Router Cisco
  5. Software PuTTY
  6. Akses Internet

Langkah-langkah:

  1. Masukkan kabel Console pada port RJ45 di Laptop dan port Console pada
    Router Cisco
  2. Masuk ke “Device Manager” cek pada driver COM (sebelumnya harus
    menginstall drive Consolenya terlebih dahulu)
  3. Masuk ke Software PuTTY, pilih “Serial” dan masukkan “Serial Line” dengan
    COM yang sesuai
  4. Sambungkan kabel LAN (Straight) ke Router pada port (bebas) menuju ke
    Laptop atau Komputer
  5. Set IP pada Router dan Laptop, pastikan Laptop dalam satu network yang sama
    dengan Router

Topologi

Topologi NAT Dynamic

Konfigurasi

R1(config)#ip route 0.0.0.0 0.0.0.0 (IP Next Hop)

R1(config)#access-list 1 permit any

R1(config)#ip nat inside source list 1 int gig0/0 overload

R1(config)#int gig0/0

R1(config-if)#ip nat outside

R1(config-if)#exit

R1(config-if)#int gig0/1

R1(config-if)#ip nat inside R1(config-if)#exit

Video Penjelasan:

Konfigurasi ACL Standard Pada Router Cisco

Perangkat yang diperlukan:

  1. Laptop
  2. Kabel Console
  3. Kabel LAN
  4. Router Cisco
  5. Software PuTTY

Langkah-langkah:

  1. Masukkan kabel Console pada port RJ45 di Laptop dan port Console pada Router Cisco
  2. Masuk ke “Device Manager” cek pada driver COM (sebelumnya harus menginstall drive Consolenya terlebih dahulu)
  3. Masuk ke Software PuTTY, pilih “Serial” dan masukkan “Serial Line” dengan COM yang sesuai
  4. Sambungkan kabel LAN (Straight) ke Router pada port (bebas) menuju ke Laptop atau Komputer
  5. Set IP pada Router dan Laptop, pastikan Laptop dalam satu network yang sama dengan Router

Topologi

Topologi ACL Standard

Konfigurasi:

R1(config)#access-list 1 deny host (IP Target)

R1(config)#access-list 1 permit any

R1(config)#int gig0/1

R1(config-if)#ip access-group 1 out R1(config-if)#exit

Video Penjelasan:

Konfigurasi Port Security Pada Switch Cisco

Perangkat yang diperlukan:

  1. Laptop
  2. Kabel Console
  3. Switch Cisco (Manageable)
  4. Software PuTTY

Langkah-langkah:

  1. Masukkan kabel Console pada port RJ45 di Laptop dan port Console pada Switch Cisco
  2. Masuk ke “Device Manager” cek pada driver COM (sebelumnya harus menginstall drive Consolenya terlebih dahulu)
  3. Masuk ke Software PuTTY, pilih “Serial” dan masukkan “Serial Line” dengan COM yang sesuai
  4. Sambungkan kabel LAN (Straight) ke Switch pada port (bebas) menuju ke Laptop atau Komputer
  5. Set IP pada Laptop, pastikan Laptop dalam satu network yang sama dengan Laptop lain

Topologi

Topologi Switchport Security

Konfigurasi:

SW-1(config)# int gig0/2

SW-1(config-if)#switchport port-security

SW-1(config-if)#switchport port-security mac-address (Mac Address / Sticky)

SW-1(config-if)#switchport port-security maximum 1 SW-1(config-if)#switchport port-security violation shutdown

Video Penjelasan:

You may also like...

Leave a Reply

Your email address will not be published.